スキルキット
文字

SSL

正式名:Secure Sockets Layer

読み:えすえすえる

ひとことで言うと

ウェブサーバとブラウザの間などの通信を暗号化して、盗み見や書き換えを防ぐための通信の決まり。今は、より安全な後継の決まりに置き換えられている。

出典

IPA ITパスポート試験 平成30年度秋期 公開問題 問71(印刷29ページ。問題文「HTTPSで接続したWebサーバとブラウザ間の暗号化通信に利用されるプロトコルはどれか。」、公式の正答エ「SSL/TLS」)
www3.jitec.ipa.go.jp

IETF RFC 6101「The Secure Sockets Layer (SSL) Protocol Version 3.0」 Abstract「a security protocol that provides communications privacy over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery.」
www.rfc-editor.org

IETF RFC 7568「Deprecating Secure Sockets Layer Version 3.0」 Abstract「This document requires that SSLv3 not be used. The replacement versions, in particular, Transport Layer Security (TLS) 1.2 (RFC 5246), are considerably more secure and capable protocols.」
www.rfc-editor.org

確認した日:2026-10-20

この用語の誤りを知らせる